Back to overview
Degraded

Global SaaS Status is degraded

Apr 12, 2025 at 8:27pm UTC
Affected services
Global SaaS Status

Resolved
Apr 12, 2025 at 8:57pm UTC

Global SaaS Status recovered.

Created
Apr 12, 2025 at 8:27pm UTC

Global SaaS Status is degraded.