Global SaaS Status is degraded
Resolved
Apr 14, 2025 at 3:27am UTC
Global SaaS Status recovered.
Affected services
Updated
Apr 14, 2025 at 3:14am UTC
Global SaaS Status is degraded.
Affected services
Updated
Apr 14, 2025 at 1:36am UTC
Global SaaS Status recovered.
Affected services
Updated
Apr 14, 2025 at 1:09am UTC
Global SaaS Status is degraded.
Affected services
Updated
Apr 14, 2025 at 12:36am UTC
Global SaaS Status recovered.
Affected services
Updated
Apr 14, 2025 at 12:31am UTC
Global SaaS Status is degraded.
Affected services
Updated
Apr 14, 2025 at 12:30am UTC
Global SaaS Status recovered.
Affected services
Created
Apr 14, 2025 at 12:17am UTC
Global SaaS Status is degraded.
Affected services