Global SaaS Status is degraded
Resolved
Apr 21, 2025 at 3:26am UTC
Global SaaS Status recovered.
Affected services
Updated
Apr 21, 2025 at 3:17am UTC
Global SaaS Status is degraded.
Affected services
Updated
Apr 21, 2025 at 1:34am UTC
Global SaaS Status recovered.
Affected services
Updated
Apr 21, 2025 at 1:21am UTC
Global SaaS Status is degraded.
Affected services
Updated
Apr 21, 2025 at 12:31am UTC
Global SaaS Status recovered.
Affected services
Updated
Apr 21, 2025 at 12:21am UTC
Global SaaS Status is degraded.
Affected services
Updated
Apr 21, 2025 at 12:19am UTC
Global SaaS Status recovered.
Affected services
Created
Apr 21, 2025 at 12:11am UTC
Global SaaS Status is degraded.
Affected services