Back to overview
Degraded

Global SaaS Status is degraded

Apr 25, 2025 at 2:59pm UTC
Affected services
Global SaaS Status

Resolved
Apr 25, 2025 at 3:20pm UTC

Global SaaS Status recovered.

Created
Apr 25, 2025 at 2:59pm UTC

Global SaaS Status is degraded.