Global SaaS Status is degraded
Resolved
May 27, 2025 at 2:39pm UTC
Global SaaS Status recovered.
Affected services
Updated
May 27, 2025 at 1:33pm UTC
Global SaaS Status is degraded.
Affected services
Updated
May 27, 2025 at 9:08am UTC
Global SaaS Status recovered.
Affected services
Updated
May 27, 2025 at 8:55am UTC
Global SaaS Status is degraded.
Affected services
Updated
May 27, 2025 at 12:29am UTC
Global SaaS Status recovered.
Affected services
Updated
May 26, 2025 at 11:18pm UTC
Global SaaS Status is degraded.
Affected services
Updated
May 26, 2025 at 10:45pm UTC
Global SaaS Status recovered.
Affected services
Updated
May 26, 2025 at 10:35pm UTC
Global SaaS Status is degraded.
Affected services
Updated
May 26, 2025 at 3:20am UTC
Global SaaS Status recovered.
Affected services
Updated
May 26, 2025 at 3:09am UTC
Global SaaS Status is degraded.
Affected services
Updated
May 26, 2025 at 1:45am UTC
Global SaaS Status recovered.
Affected services
Updated
May 26, 2025 at 1:40am UTC
Global SaaS Status is degraded.
Affected services
Updated
May 26, 2025 at 1:33am UTC
Global SaaS Status recovered.
Affected services
Updated
May 26, 2025 at 1:14am UTC
Global SaaS Status is degraded.
Affected services
Updated
May 26, 2025 at 12:40am UTC
Global SaaS Status recovered.
Affected services
Updated
May 26, 2025 at 12:35am UTC
Global SaaS Status is degraded.
Affected services
Updated
May 26, 2025 at 12:35am UTC
Global SaaS Status recovered.
Affected services
Created
May 25, 2025 at 11:15pm UTC
Global SaaS Status is degraded.
Affected services