Global SaaS Status is degraded
Resolved
Jul 7, 2025 at 5:21am UTC
Global SaaS Status recovered.
Affected services
Updated
Jul 7, 2025 at 5:14am UTC
Global SaaS Status is degraded.
Affected services
Updated
Jul 7, 2025 at 3:34am UTC
Global SaaS Status recovered.
Affected services
Updated
Jul 7, 2025 at 3:19am UTC
Global SaaS Status is degraded.
Affected services
Updated
Jul 7, 2025 at 3:17am UTC
Global SaaS Status recovered.
Affected services
Updated
Jul 7, 2025 at 3:09am UTC
Global SaaS Status is degraded.
Affected services
Updated
Jul 7, 2025 at 1:35am UTC
Global SaaS Status recovered.
Affected services
Updated
Jul 7, 2025 at 1:25am UTC
Global SaaS Status is degraded.
Affected services
Updated
Jul 7, 2025 at 12:29am UTC
Global SaaS Status recovered.
Affected services
Created
Jul 7, 2025 at 12:16am UTC
Global SaaS Status is degraded.
Affected services