Global SaaS Status and ManagementDB USA are down
Resolved
Jul 21, 2025 at 3:37am UTC
Global SaaS Status recovered.
Affected services
Updated
Jul 21, 2025 at 3:31am UTC
Global SaaS Status is degraded.
Affected services
Updated
Jul 21, 2025 at 3:25am UTC
Global SaaS Status recovered.
Affected services
Updated
Jul 21, 2025 at 3:14am UTC
Global SaaS Status is degraded.
Affected services
Updated
Jul 21, 2025 at 3:10am UTC
Global SaaS Status recovered.
Affected services
Updated
Jul 21, 2025 at 3:05am UTC
Global SaaS Status is degraded.
Affected services
Updated
Jul 21, 2025 at 1:21am UTC
ManagementDB USA recovered.
Affected services
Updated
Jul 21, 2025 at 12:38am UTC
Global SaaS Status recovered.
Affected services
Updated
Jul 21, 2025 at 12:35am UTC
ManagementDB USA is degraded.
Affected services
Created
Jul 21, 2025 at 12:24am UTC
Global SaaS Status is degraded.
Affected services