Global SaaS Status, AnalyticsDB USA, and 1 other service are down
Resolved
Jul 26, 2025 at 8:16pm UTC
ManagementDB Europe recovered.
Affected services
Updated
Jul 26, 2025 at 8:05pm UTC
ManagementDB Europe is degraded.
Affected services
Updated
Jul 26, 2025 at 3:09pm UTC
Global SaaS Status recovered.
Affected services
Updated
Jul 26, 2025 at 12:14pm UTC
Global SaaS Status is degraded.
Affected services
Updated
Jul 26, 2025 at 12:10pm UTC
Global SaaS Status recovered.
Affected services
Updated
Jul 26, 2025 at 9:37am UTC
AnalyticsDB USA recovered.
Affected services
Updated
Jul 26, 2025 at 5:49am UTC
AnalyticsDB USA is degraded.
Affected services
Updated
Jul 26, 2025 at 5:31am UTC
ManagementDB Europe recovered.
Affected services
Updated
Jul 26, 2025 at 1:01am UTC
ManagementDB Europe is degraded.
Affected services
Created
Jul 26, 2025 at 12:13am UTC
Global SaaS Status is degraded.
Affected services