Global SaaS Status is degraded
Resolved
Aug 4, 2025 at 6:00pm UTC
Global SaaS Status recovered.
Affected services
Updated
Aug 4, 2025 at 5:48pm UTC
Global SaaS Status is degraded.
Affected services
Updated
Aug 4, 2025 at 3:23pm UTC
Global SaaS Status recovered.
Affected services
Updated
Aug 4, 2025 at 3:13pm UTC
Global SaaS Status is degraded.
Affected services
Updated
Aug 4, 2025 at 1:56am UTC
Global SaaS Status recovered.
Affected services
Updated
Aug 4, 2025 at 1:51am UTC
Global SaaS Status is degraded.
Affected services
Updated
Aug 4, 2025 at 1:47am UTC
Global SaaS Status recovered.
Affected services
Updated
Aug 4, 2025 at 1:38am UTC
Global SaaS Status is degraded.
Affected services
Updated
Aug 4, 2025 at 1:22am UTC
Global SaaS Status recovered.
Affected services
Updated
Aug 4, 2025 at 1:15am UTC
Global SaaS Status is degraded.
Affected services
Updated
Aug 4, 2025 at 1:12am UTC
Global SaaS Status recovered.
Affected services
Updated
Aug 4, 2025 at 1:04am UTC
Global SaaS Status is degraded.
Affected services
Updated
Aug 4, 2025 at 12:26am UTC
Global SaaS Status recovered.
Affected services
Created
Aug 4, 2025 at 12:15am UTC
Global SaaS Status is degraded.
Affected services