Global SaaS Status is degraded
Resolved
Aug 5, 2025 at 9:15pm UTC
Global SaaS Status recovered.
Affected services
Updated
Aug 5, 2025 at 8:40pm UTC
Global SaaS Status is degraded.
Affected services
Updated
Aug 5, 2025 at 8:32am UTC
Global SaaS Status recovered.
Affected services
Updated
Aug 5, 2025 at 8:22am UTC
Global SaaS Status is degraded.
Affected services
Updated
Aug 5, 2025 at 6:57am UTC
Global SaaS Status recovered.
Affected services
Updated
Aug 5, 2025 at 6:51am UTC
Global SaaS Status is degraded.
Affected services
Updated
Aug 5, 2025 at 6:48am UTC
Global SaaS Status recovered.
Affected services
Created
Aug 5, 2025 at 6:42am UTC
Global SaaS Status is degraded.
Affected services