Global SaaS Status is down
Resolved
Aug 09 at 01:53am CEST
Global SaaS Status recovered.
Affected services
Updated
Aug 09 at 12:58am CEST
Global SaaS Status is degraded.
Affected services
Updated
Aug 09 at 12:05am CEST
Global SaaS Status recovered.
Affected services
Updated
Aug 08 at 11:39pm CEST
Global SaaS Status is degraded.
Affected services
Updated
Aug 08 at 10:42pm CEST
Global SaaS Status recovered.
Affected services
Updated
Aug 08 at 10:25pm CEST
Global SaaS Status is degraded.
Affected services
Updated
Aug 08 at 09:24pm CEST
Global SaaS Status recovered.
Affected services
Updated
Aug 08 at 08:44pm CEST
Global SaaS Status is degraded.
Affected services
Updated
Aug 08 at 07:30pm CEST
Global SaaS Status recovered.
Affected services
Updated
Aug 08 at 06:59pm CEST
Global SaaS Status is degraded.
Affected services
Updated
Aug 08 at 07:51am CEST
Global SaaS Status recovered.
Affected services
Created
Aug 08 at 07:02am CEST
Global SaaS Status is degraded.
Affected services