Global SaaS Status is degraded
Resolved
Aug 10, 2025 at 10:39pm UTC
Global SaaS Status recovered.
Affected services
Updated
Aug 10, 2025 at 10:05pm UTC
Global SaaS Status is degraded.
Affected services
Updated
Aug 10, 2025 at 8:56pm UTC
Global SaaS Status recovered.
Affected services
Updated
Aug 10, 2025 at 8:16pm UTC
Global SaaS Status is degraded.
Affected services
Updated
Aug 10, 2025 at 6:07pm UTC
Global SaaS Status recovered.
Affected services
Updated
Aug 10, 2025 at 5:27pm UTC
Global SaaS Status is degraded.
Affected services
Updated
Aug 10, 2025 at 4:29pm UTC
Global SaaS Status recovered.
Affected services
Updated
Aug 10, 2025 at 3:46pm UTC
Global SaaS Status is degraded.
Affected services
Updated
Aug 10, 2025 at 2:56pm UTC
Global SaaS Status recovered.
Affected services
Updated
Aug 10, 2025 at 2:10pm UTC
Global SaaS Status is degraded.
Affected services
Updated
Aug 10, 2025 at 1:20pm UTC
Global SaaS Status recovered.
Affected services
Updated
Aug 10, 2025 at 12:42pm UTC
Global SaaS Status is degraded.
Affected services
Updated
Aug 10, 2025 at 11:37am UTC
Global SaaS Status recovered.
Affected services
Updated
Aug 10, 2025 at 10:53am UTC
Global SaaS Status is degraded.
Affected services
Updated
Aug 10, 2025 at 9:47am UTC
Global SaaS Status recovered.
Affected services
Updated
Aug 10, 2025 at 9:05am UTC
Global SaaS Status is degraded.
Affected services
Updated
Aug 10, 2025 at 8:16am UTC
Global SaaS Status recovered.
Affected services
Updated
Aug 10, 2025 at 7:26am UTC
Global SaaS Status is degraded.
Affected services
Updated
Aug 10, 2025 at 6:36am UTC
Global SaaS Status recovered.
Affected services
Updated
Aug 10, 2025 at 5:57am UTC
Global SaaS Status is degraded.
Affected services
Updated
Aug 10, 2025 at 4:33am UTC
Global SaaS Status recovered.
Affected services
Updated
Aug 10, 2025 at 3:46am UTC
Global SaaS Status is degraded.
Affected services
Updated
Aug 10, 2025 at 2:22am UTC
Global SaaS Status recovered.
Affected services
Updated
Aug 10, 2025 at 1:42am UTC
Global SaaS Status is degraded.
Affected services
Updated
Aug 10, 2025 at 12:08am UTC
Global SaaS Status recovered.
Affected services
Updated
Aug 9, 2025 at 11:22pm UTC
Global SaaS Status is degraded.
Affected services
Updated
Aug 9, 2025 at 9:35pm UTC
Global SaaS Status recovered.
Affected services
Updated
Aug 9, 2025 at 8:59pm UTC
Global SaaS Status is degraded.
Affected services
Updated
Aug 9, 2025 at 8:07pm UTC
Global SaaS Status recovered.
Affected services
Updated
Aug 9, 2025 at 7:26pm UTC
Global SaaS Status is degraded.
Affected services
Updated
Aug 9, 2025 at 5:43pm UTC
Global SaaS Status recovered.
Affected services
Updated
Aug 9, 2025 at 5:12pm UTC
Global SaaS Status is degraded.
Affected services
Updated
Aug 9, 2025 at 4:08pm UTC
Global SaaS Status recovered.
Affected services
Updated
Aug 9, 2025 at 3:47pm UTC
Global SaaS Status is degraded.
Affected services
Updated
Aug 9, 2025 at 1:26pm UTC
Global SaaS Status recovered.
Affected services
Updated
Aug 9, 2025 at 12:51pm UTC
Global SaaS Status is degraded.
Affected services
Updated
Aug 9, 2025 at 11:28am UTC
Global SaaS Status recovered.
Affected services
Updated
Aug 9, 2025 at 10:45am UTC
Global SaaS Status is degraded.
Affected services
Updated
Aug 9, 2025 at 7:24am UTC
Global SaaS Status recovered.
Affected services
Updated
Aug 9, 2025 at 6:43am UTC
Global SaaS Status is degraded.
Affected services
Updated
Aug 9, 2025 at 4:42am UTC
Global SaaS Status recovered.
Affected services
Updated
Aug 9, 2025 at 3:59am UTC
Global SaaS Status is degraded.
Affected services
Updated
Aug 9, 2025 at 1:54am UTC
Global SaaS Status recovered.
Affected services
Created
Aug 9, 2025 at 1:15am UTC
Global SaaS Status is degraded.
Affected services