Back to overview
Degraded

Global SaaS Status is degraded

Sep 1, 2025 at 3:24am UTC
Affected services
Global SaaS Status

Resolved
Sep 1, 2025 at 3:52am UTC

Global SaaS Status recovered.

Updated
Sep 1, 2025 at 3:46am UTC

Global SaaS Status is degraded.

Updated
Sep 1, 2025 at 3:44am UTC

Global SaaS Status recovered.

Updated
Sep 1, 2025 at 3:38am UTC

Global SaaS Status is degraded.

Updated
Sep 1, 2025 at 3:29am UTC

Global SaaS Status recovered.

Created
Sep 1, 2025 at 3:24am UTC

Global SaaS Status is degraded.