Global SaaS Status is down
Resolved
Sep 29, 2025 at 3:43am UTC
Global SaaS Status recovered.
Affected services
Updated
Sep 29, 2025 at 3:37am UTC
Global SaaS Status is degraded.
Affected services
Updated
Sep 29, 2025 at 3:25am UTC
Global SaaS Status recovered.
Affected services
Updated
Sep 29, 2025 at 3:15am UTC
Global SaaS Status is degraded.
Affected services
Updated
Sep 29, 2025 at 3:10am UTC
Global SaaS Status recovered.
Affected services
Updated
Sep 29, 2025 at 3:04am UTC
Global SaaS Status is degraded.
Affected services
Updated
Sep 29, 2025 at 2:17am UTC
Global SaaS Status recovered.
Affected services
Updated
Sep 29, 2025 at 2:12am UTC
Global SaaS Status is degraded.
Affected services
Updated
Sep 29, 2025 at 1:54am UTC
Global SaaS Status recovered.
Affected services
Updated
Sep 29, 2025 at 1:40am UTC
Global SaaS Status is degraded.
Affected services
Updated
Sep 29, 2025 at 1:35am UTC
Global SaaS Status recovered.
Affected services
Updated
Sep 29, 2025 at 1:25am UTC
Global SaaS Status is degraded.
Affected services
Updated
Sep 29, 2025 at 1:21am UTC
Global SaaS Status recovered.
Affected services
Updated
Sep 29, 2025 at 1:15am UTC
Global SaaS Status is degraded.
Affected services
Updated
Sep 29, 2025 at 12:30am UTC
Global SaaS Status recovered.
Affected services
Updated
Sep 29, 2025 at 12:20am UTC
Global SaaS Status is degraded.
Affected services
Updated
Sep 29, 2025 at 12:16am UTC
Global SaaS Status recovered.
Affected services
Created
Sep 29, 2025 at 12:09am UTC
Global SaaS Status is degraded.
Affected services