Global SaaS Status is down
Resolved
Oct 13, 2025 at 8:17pm UTC
Global SaaS Status recovered.
Affected services
Updated
Oct 13, 2025 at 7:40pm UTC
Global SaaS Status is degraded.
Affected services
Updated
Oct 13, 2025 at 7:13pm UTC
Global SaaS Status recovered.
Affected services
Updated
Oct 13, 2025 at 7:08pm UTC
Global SaaS Status is degraded.
Affected services
Updated
Oct 13, 2025 at 1:34pm UTC
Global SaaS Status recovered.
Affected services
Updated
Oct 13, 2025 at 1:24pm UTC
Global SaaS Status is degraded.
Affected services
Updated
Oct 13, 2025 at 12:52pm UTC
Global SaaS Status recovered.
Affected services
Updated
Oct 13, 2025 at 12:38pm UTC
Global SaaS Status is degraded.
Affected services
Updated
Oct 13, 2025 at 10:57am UTC
Global SaaS Status recovered.
Affected services
Updated
Oct 13, 2025 at 10:50am UTC
Global SaaS Status is degraded.
Affected services
Updated
Oct 13, 2025 at 10:45am UTC
Global SaaS Status recovered.
Affected services
Updated
Oct 13, 2025 at 9:05am UTC
Global SaaS Status is degraded.
Affected services
Updated
Oct 13, 2025 at 3:50am UTC
Global SaaS Status recovered.
Affected services
Updated
Oct 13, 2025 at 3:38am UTC
Global SaaS Status is degraded.
Affected services
Updated
Oct 13, 2025 at 3:21am UTC
Global SaaS Status recovered.
Affected services
Created
Oct 13, 2025 at 3:14am UTC
Global SaaS Status is degraded.
Affected services