Global SaaS Status is down
Resolved
Oct 15, 2025 at 8:08pm UTC
Global SaaS Status recovered.
Affected services
Updated
Oct 15, 2025 at 8:06pm UTC
Global SaaS Status is degraded.
Affected services
Updated
Oct 15, 2025 at 7:53pm UTC
Global SaaS Status recovered.
Affected services
Updated
Oct 15, 2025 at 7:44pm UTC
Global SaaS Status is degraded.
Affected services
Updated
Oct 15, 2025 at 7:36pm UTC
Global SaaS Status recovered.
Affected services
Updated
Oct 15, 2025 at 7:34pm UTC
Global SaaS Status is degraded.
Affected services
Updated
Oct 15, 2025 at 3:08pm UTC
Global SaaS Status recovered.
Affected services
Updated
Oct 15, 2025 at 2:45pm UTC
Global SaaS Status is degraded.
Affected services
Updated
Oct 15, 2025 at 2:44pm UTC
Global SaaS Status recovered.
Affected services
Updated
Oct 15, 2025 at 2:34pm UTC
Global SaaS Status is degraded.
Affected services
Updated
Oct 15, 2025 at 1:14pm UTC
Global SaaS Status recovered.
Affected services
Updated
Oct 15, 2025 at 1:10pm UTC
Global SaaS Status is degraded.
Affected services
Updated
Oct 15, 2025 at 12:46pm UTC
Global SaaS Status recovered.
Affected services
Updated
Oct 15, 2025 at 12:39pm UTC
Global SaaS Status is degraded.
Affected services
Updated
Oct 15, 2025 at 12:33pm UTC
Global SaaS Status recovered.
Affected services
Updated
Oct 15, 2025 at 12:22pm UTC
Global SaaS Status is degraded.
Affected services
Updated
Oct 15, 2025 at 12:08pm UTC
Global SaaS Status recovered.
Affected services
Updated
Oct 15, 2025 at 12:02pm UTC
Global SaaS Status is degraded.
Affected services
Updated
Oct 15, 2025 at 11:14am UTC
Global SaaS Status recovered.
Affected services
Created
Oct 15, 2025 at 10:15am UTC
Global SaaS Status is degraded.
Affected services