Back to overview
Degraded

Global SaaS Status is down

Oct 20, 2025 at 3:21am UTC
Affected services
Global SaaS Status

Resolved
Oct 20, 2025 at 12:18pm UTC

Global SaaS Status recovered.

Updated
Oct 20, 2025 at 12:07pm UTC

Global SaaS Status is degraded.

Updated
Oct 20, 2025 at 3:50am UTC

Global SaaS Status recovered.

Updated
Oct 20, 2025 at 3:44am UTC

Global SaaS Status is degraded.

Updated
Oct 20, 2025 at 3:36am UTC

Global SaaS Status recovered.

Created
Oct 20, 2025 at 3:21am UTC

Global SaaS Status is degraded.