Back to overview
Degraded

Global SaaS Status is down

Oct 27, 2025 at 12:14am UTC
Affected services
Global SaaS Status

Resolved
Oct 27, 2025 at 4:18am UTC

Global SaaS Status recovered.

Updated
Oct 27, 2025 at 4:12am UTC

Global SaaS Status is degraded.

Updated
Oct 27, 2025 at 3:49am UTC

Global SaaS Status recovered.

Updated
Oct 27, 2025 at 3:40am UTC

Global SaaS Status is degraded.

Updated
Oct 27, 2025 at 3:40am UTC

Global SaaS Status recovered.

Updated
Oct 27, 2025 at 3:34am UTC

Global SaaS Status is degraded.

Updated
Oct 27, 2025 at 3:33am UTC

Global SaaS Status recovered.

Updated
Oct 27, 2025 at 3:27am UTC

Global SaaS Status is degraded.

Updated
Oct 27, 2025 at 3:23am UTC

Global SaaS Status recovered.

Updated
Oct 27, 2025 at 3:14am UTC

Global SaaS Status is degraded.

Updated
Oct 27, 2025 at 12:19am UTC

Global SaaS Status recovered.

Created
Oct 27, 2025 at 12:14am UTC

Global SaaS Status is degraded.