Global SaaS Status is down
Resolved
Oct 28, 2025 at 3:57pm UTC
Global SaaS Status recovered.
Affected services
Updated
Oct 28, 2025 at 3:54pm UTC
Global SaaS Status is degraded.
Affected services
Updated
Oct 28, 2025 at 3:54pm UTC
Global SaaS Status recovered.
Affected services
Updated
Oct 28, 2025 at 3:48pm UTC
Global SaaS Status is degraded.
Affected services
Updated
Oct 28, 2025 at 2:26pm UTC
Global SaaS Status recovered.
Affected services
Updated
Oct 28, 2025 at 2:20pm UTC
Global SaaS Status is degraded.
Affected services
Updated
Oct 28, 2025 at 2:17pm UTC
Global SaaS Status recovered.
Affected services
Created
Oct 28, 2025 at 2:12pm UTC
Global SaaS Status is degraded.
Affected services