Global SaaS Status is down
Resolved
Oct 29, 2025 at 3:07pm UTC
Global SaaS Status recovered.
Affected services
Updated
Oct 29, 2025 at 2:59pm UTC
Global SaaS Status is degraded.
Affected services
Updated
Oct 29, 2025 at 1:23pm UTC
Global SaaS Status recovered.
Affected services
Updated
Oct 29, 2025 at 11:35am UTC
Global SaaS Status is degraded.
Affected services
Updated
Oct 29, 2025 at 11:32am UTC
Global SaaS Status recovered.
Affected services
Updated
Oct 29, 2025 at 11:09am UTC
Global SaaS Status is degraded.
Affected services
Updated
Oct 29, 2025 at 11:07am UTC
Global SaaS Status recovered.
Affected services
Updated
Oct 29, 2025 at 10:23am UTC
Global SaaS Status is degraded.
Affected services
Updated
Oct 29, 2025 at 9:46am UTC
Global SaaS Status recovered.
Affected services
Created
Oct 29, 2025 at 8:47am UTC
Global SaaS Status is degraded.
Affected services