Global SaaS Status and AnalyticsDB WestEurope are down
Resolved
Nov 4, 2025 at 5:02pm UTC
Global SaaS Status recovered.
Affected services
Updated
Nov 4, 2025 at 4:56pm UTC
Global SaaS Status is degraded.
Affected services
Updated
Nov 4, 2025 at 4:54pm UTC
Global SaaS Status recovered.
Affected services
Updated
Nov 4, 2025 at 3:42pm UTC
Global SaaS Status is degraded.
Affected services
Updated
Nov 4, 2025 at 9:22am UTC
Global SaaS Status recovered.
Affected services
Updated
Nov 4, 2025 at 9:13am UTC
Global SaaS Status is degraded.
Affected services
Updated
Nov 4, 2025 at 8:27am UTC
Global SaaS Status recovered.
Affected services
Updated
Nov 3, 2025 at 4:38pm UTC
Global SaaS Status is degraded.
Affected services
Updated
Nov 3, 2025 at 1:50pm UTC
AnalyticsDB WestEurope recovered.
Affected services
Updated
Nov 3, 2025 at 11:17am UTC
AnalyticsDB WestEurope is degraded.
Affected services
Updated
Nov 3, 2025 at 3:53am UTC
Global SaaS Status recovered.
Affected services
Updated
Nov 3, 2025 at 3:47am UTC
Global SaaS Status is degraded.
Affected services
Updated
Nov 3, 2025 at 3:27am UTC
Global SaaS Status recovered.
Affected services
Created
Nov 3, 2025 at 3:04am UTC
Global SaaS Status is degraded.
Affected services