Global SaaS Status is down
Resolved
Nov 25 at 06:05pm CET
Global SaaS Status recovered.
Affected services
Updated
Nov 25 at 06:01pm CET
Global SaaS Status is degraded.
Affected services
Updated
Nov 25 at 04:13pm CET
Global SaaS Status recovered.
Affected services
Updated
Nov 25 at 03:49pm CET
Global SaaS Status is degraded.
Affected services
Updated
Nov 25 at 02:34pm CET
Global SaaS Status recovered.
Affected services
Updated
Nov 25 at 02:00pm CET
Global SaaS Status is degraded.
Affected services
Updated
Nov 25 at 11:48am CET
Global SaaS Status recovered.
Affected services
Updated
Nov 25 at 11:40am CET
Global SaaS Status is degraded.
Affected services
Updated
Nov 25 at 07:47am CET
Global SaaS Status recovered.
Affected services
Created
Nov 25 at 07:39am CET
Global SaaS Status is degraded.
Affected services