Back to overview
Degraded

Global SaaS Status is down

Nov 27, 2025 at 5:51am UTC
Affected services
Global SaaS Status

Resolved
Nov 27, 2025 at 10:15am UTC

Global SaaS Status recovered.

Updated
Nov 27, 2025 at 10:10am UTC

Global SaaS Status is degraded.

Updated
Nov 27, 2025 at 5:57am UTC

Global SaaS Status recovered.

Created
Nov 27, 2025 at 5:51am UTC

Global SaaS Status is degraded.