Global SaaS Status is down
Resolved
Feb 2, 2026 at 10:36pm UTC
Global SaaS Status recovered.
Affected services
Updated
Feb 2, 2026 at 10:30pm UTC
Global SaaS Status is degraded.
Affected services
Updated
Feb 2, 2026 at 7:30pm UTC
Global SaaS Status recovered.
Affected services
Updated
Feb 2, 2026 at 7:20pm UTC
Global SaaS Status is degraded.
Affected services
Updated
Feb 2, 2026 at 7:02pm UTC
Global SaaS Status recovered.
Affected services
Updated
Feb 2, 2026 at 6:51pm UTC
Global SaaS Status is degraded.
Affected services
Updated
Feb 2, 2026 at 5:48pm UTC
Global SaaS Status recovered.
Affected services
Updated
Feb 2, 2026 at 5:23pm UTC
Global SaaS Status is degraded.
Affected services
Updated
Feb 2, 2026 at 5:12pm UTC
Global SaaS Status recovered.
Affected services
Updated
Feb 2, 2026 at 5:07pm UTC
Global SaaS Status is degraded.
Affected services
Updated
Feb 2, 2026 at 9:26am UTC
Global SaaS Status recovered.
Affected services
Updated
Feb 2, 2026 at 7:21am UTC
Global SaaS Status is degraded.
Affected services
Updated
Feb 2, 2026 at 2:42am UTC
Global SaaS Status recovered.
Affected services
Updated
Feb 2, 2026 at 2:36am UTC
Global SaaS Status is degraded.
Affected services
Updated
Feb 2, 2026 at 1:47am UTC
Global SaaS Status recovered.
Affected services
Updated
Feb 2, 2026 at 1:42am UTC
Global SaaS Status is degraded.
Affected services
Updated
Feb 2, 2026 at 1:41am UTC
Global SaaS Status recovered.
Affected services
Updated
Feb 2, 2026 at 1:35am UTC
Global SaaS Status is degraded.
Affected services
Updated
Feb 2, 2026 at 1:30am UTC
Global SaaS Status recovered.
Affected services
Updated
Feb 2, 2026 at 1:20am UTC
Global SaaS Status is degraded.
Affected services
Updated
Feb 2, 2026 at 12:55am UTC
Global SaaS Status recovered.
Affected services
Updated
Feb 2, 2026 at 12:49am UTC
Global SaaS Status is degraded.
Affected services
Updated
Feb 2, 2026 at 12:36am UTC
Global SaaS Status recovered.
Affected services
Updated
Feb 2, 2026 at 12:19am UTC
Global SaaS Status is degraded.
Affected services
Updated
Feb 2, 2026 at 12:15am UTC
Global SaaS Status recovered.
Affected services
Created
Feb 2, 2026 at 12:10am UTC
Global SaaS Status is degraded.
Affected services