Global SaaS Status is down
Resolved
Feb 16, 2026 at 4:45am UTC
Global SaaS Status recovered.
Affected services
Updated
Feb 16, 2026 at 4:36am UTC
Global SaaS Status is degraded.
Affected services
Updated
Feb 16, 2026 at 4:12am UTC
Global SaaS Status recovered.
Affected services
Updated
Feb 16, 2026 at 4:07am UTC
Global SaaS Status is degraded.
Affected services
Updated
Feb 16, 2026 at 3:50am UTC
Global SaaS Status recovered.
Affected services
Updated
Feb 16, 2026 at 3:45am UTC
Global SaaS Status is degraded.
Affected services
Updated
Feb 16, 2026 at 3:41am UTC
Global SaaS Status recovered.
Affected services
Updated
Feb 16, 2026 at 3:35am UTC
Global SaaS Status is degraded.
Affected services
Updated
Feb 16, 2026 at 3:25am UTC
Global SaaS Status recovered.
Affected services
Updated
Feb 16, 2026 at 3:15am UTC
Global SaaS Status is degraded.
Affected services
Updated
Feb 16, 2026 at 12:30am UTC
Global SaaS Status recovered.
Affected services
Created
Feb 16, 2026 at 12:19am UTC
Global SaaS Status is degraded.
Affected services