Back to overview
Degraded

Global SaaS Status, ManagementDB APAC, and 1 other service are down

Mar 3, 2026 at 11:13pm UTC
Affected services
Global SaaS Status
ManagementDB APAC
ManagementDB Europe

Resolved
Mar 4, 2026 at 5:53pm UTC

ManagementDB APAC and ManagementDB Europe recovered.

Updated
Mar 4, 2026 at 5:48pm UTC

ManagementDB APAC and ManagementDB Europe are degraded.

Updated
Mar 4, 2026 at 5:40pm UTC

ManagementDB Europe recovered.

Updated
Mar 4, 2026 at 5:34pm UTC

ManagementDB Europe is degraded.

Updated
Mar 4, 2026 at 5:30pm UTC

ManagementDB Europe recovered.

Updated
Mar 4, 2026 at 5:23pm UTC

ManagementDB Europe is degraded.

Updated
Mar 4, 2026 at 7:29am UTC

Global SaaS Status recovered.

Updated
Mar 4, 2026 at 7:23am UTC

Global SaaS Status is degraded.

Updated
Mar 4, 2026 at 2:33am UTC

Global SaaS Status recovered.

Updated
Mar 4, 2026 at 2:21am UTC

Global SaaS Status is degraded.

Updated
Mar 4, 2026 at 2:05am UTC

Global SaaS Status recovered.

Created
Mar 3, 2026 at 11:13pm UTC

Global SaaS Status is degraded.