Global SaaS Status is down
Resolved
Mar 6, 2026 at 11:30pm UTC
Global SaaS Status recovered.
Affected services
Updated
Mar 6, 2026 at 11:20pm UTC
Global SaaS Status is degraded.
Affected services
Updated
Mar 6, 2026 at 2:39pm UTC
Global SaaS Status recovered.
Affected services
Updated
Mar 6, 2026 at 2:25pm UTC
Global SaaS Status is degraded.
Affected services
Updated
Mar 6, 2026 at 11:39am UTC
Global SaaS Status recovered.
Affected services
Updated
Mar 6, 2026 at 11:33am UTC
Global SaaS Status is degraded.
Affected services
Updated
Mar 6, 2026 at 2:07am UTC
Global SaaS Status recovered.
Affected services
Updated
Mar 6, 2026 at 1:56am UTC
Global SaaS Status is degraded.
Affected services
Updated
Mar 6, 2026 at 1:51am UTC
Global SaaS Status recovered.
Affected services
Created
Mar 6, 2026 at 1:45am UTC
Global SaaS Status is degraded.
Affected services