Global SaaS Status is down
Resolved
Mar 9, 2026 at 11:42pm UTC
Global SaaS Status recovered.
Affected services
Updated
Mar 9, 2026 at 11:15pm UTC
Global SaaS Status is degraded.
Affected services
Updated
Mar 9, 2026 at 1:55pm UTC
Global SaaS Status recovered.
Affected services
Updated
Mar 9, 2026 at 1:49pm UTC
Global SaaS Status is degraded.
Affected services
Updated
Mar 9, 2026 at 10:56am UTC
Global SaaS Status recovered.
Affected services
Updated
Mar 9, 2026 at 10:32am UTC
Global SaaS Status is degraded.
Affected services
Updated
Mar 9, 2026 at 4:18am UTC
Global SaaS Status recovered.
Affected services
Updated
Mar 9, 2026 at 4:12am UTC
Global SaaS Status is degraded.
Affected services
Updated
Mar 9, 2026 at 4:05am UTC
Global SaaS Status recovered.
Affected services
Updated
Mar 9, 2026 at 4:00am UTC
Global SaaS Status is degraded.
Affected services
Updated
Mar 9, 2026 at 3:44am UTC
Global SaaS Status recovered.
Affected services
Updated
Mar 9, 2026 at 3:39am UTC
Global SaaS Status is degraded.
Affected services
Updated
Mar 9, 2026 at 3:38am UTC
Global SaaS Status recovered.
Affected services
Updated
Mar 9, 2026 at 3:33am UTC
Global SaaS Status is degraded.
Affected services
Updated
Mar 9, 2026 at 3:32am UTC
Global SaaS Status recovered.
Affected services
Updated
Mar 9, 2026 at 3:26am UTC
Global SaaS Status is degraded.
Affected services
Updated
Mar 9, 2026 at 3:21am UTC
Global SaaS Status recovered.
Affected services
Updated
Mar 9, 2026 at 3:15am UTC
Global SaaS Status is degraded.
Affected services
Updated
Mar 9, 2026 at 1:58am UTC
Global SaaS Status recovered.
Affected services
Updated
Mar 9, 2026 at 1:47am UTC
Global SaaS Status is degraded.
Affected services
Updated
Mar 9, 2026 at 12:31am UTC
Global SaaS Status recovered.
Affected services
Created
Mar 9, 2026 at 12:19am UTC
Global SaaS Status is degraded.
Affected services