Back to overview
Degraded

Global SaaS Status, AnalyticsDB WestEurope, and 3 other services are down

Mar 10, 2026 at 5:11am UTC
Affected services
Global SaaS Status
AnalyticsDB WestEurope
AnalyticsDB USA
ManagementDB USA
ManagementDB Europe

Resolved
Mar 10, 2026 at 9:21pm UTC

AnalyticsDB WestEurope recovered.

Updated
Mar 10, 2026 at 9:07pm UTC

AnalyticsDB WestEurope is degraded.

Updated
Mar 10, 2026 at 7:31pm UTC

Global SaaS Status recovered.

Updated
Mar 10, 2026 at 7:30pm UTC

ManagementDB Europe recovered.

Updated
Mar 10, 2026 at 7:25pm UTC

AnalyticsDB USA recovered.

Updated
Mar 10, 2026 at 7:24pm UTC

ManagementDB Europe is degraded.

Updated
Mar 10, 2026 at 7:04pm UTC

Global SaaS Status is degraded.

Updated
Mar 10, 2026 at 7:23am UTC

ManagementDB Europe recovered.

Updated
Mar 10, 2026 at 7:22am UTC

ManagementDB USA recovered.

Updated
Mar 10, 2026 at 7:19am UTC

AnalyticsDB USA is degraded.

Updated
Mar 10, 2026 at 7:17am UTC

ManagementDB Europe is degraded.

Updated
Mar 10, 2026 at 7:16am UTC

ManagementDB USA is degraded.

Updated
Mar 10, 2026 at 6:02am UTC

Global SaaS Status recovered.

Created
Mar 10, 2026 at 5:11am UTC

Global SaaS Status is degraded.