Global SaaS Status and ManagementDB Europe are down
Resolved
Mar 16, 2026 at 12:27pm UTC
Global SaaS Status recovered.
Affected services
Updated
Mar 16, 2026 at 12:17pm UTC
Global SaaS Status is degraded.
Affected services
Updated
Mar 16, 2026 at 6:08am UTC
ManagementDB Europe recovered.
Affected services
Updated
Mar 16, 2026 at 6:03am UTC
ManagementDB Europe is degraded.
Affected services
Updated
Mar 16, 2026 at 3:46am UTC
Global SaaS Status recovered.
Affected services
Updated
Mar 16, 2026 at 3:41am UTC
Global SaaS Status is degraded.
Affected services
Updated
Mar 16, 2026 at 3:24am UTC
Global SaaS Status recovered.
Affected services
Created
Mar 16, 2026 at 3:14am UTC
Global SaaS Status is degraded.
Affected services