Back to overview
Degraded

Global SaaS Status, AnalyticsDB WestEurope, and 6 other services are down

Mar 18, 2026 at 10:09am UTC
Affected services
Global SaaS Status
AnalyticsDB WestEurope
AnalyticsDB USA
ManagementDB APAC
ManagementDB Australia
ManagementDB Canada
ManagementDB USA
ManagementDB Europe

Resolved
Mar 24, 2026 at 11:18pm UTC

ManagementDB Europe recovered.

Updated
Mar 24, 2026 at 11:15pm UTC

ManagementDB Canada recovered.

Updated
Mar 24, 2026 at 11:04pm UTC

ManagementDB USA recovered.

Updated
Mar 24, 2026 at 11:00pm UTC

ManagementDB Canada is degraded.

Updated
Mar 24, 2026 at 10:58pm UTC

ManagementDB USA is degraded.

Updated
Mar 24, 2026 at 10:20pm UTC

ManagementDB APAC recovered.

Updated
Mar 24, 2026 at 10:16pm UTC

ManagementDB USA recovered.

Updated
Mar 24, 2026 at 10:12pm UTC

ManagementDB Europe is degraded.

Updated
Mar 24, 2026 at 10:07pm UTC

ManagementDB USA is degraded.

Updated
Mar 24, 2026 at 10:05pm UTC

ManagementDB APAC is degraded.

Updated
Mar 24, 2026 at 1:45pm UTC

ManagementDB Europe recovered.

Updated
Mar 24, 2026 at 1:39pm UTC

ManagementDB Europe is degraded.

Updated
Mar 24, 2026 at 7:58am UTC

Global SaaS Status recovered.

Updated
Mar 24, 2026 at 7:00am UTC

Global SaaS Status is degraded.

Updated
Mar 24, 2026 at 6:58am UTC

Global SaaS Status recovered.

Updated
Mar 24, 2026 at 6:09am UTC

ManagementDB APAC and ManagementDB Europe recovered.

Updated
Mar 24, 2026 at 6:03am UTC

ManagementDB APAC and ManagementDB Europe are degraded.

Updated
Mar 23, 2026 at 11:33pm UTC

ManagementDB Australia recovered.

Updated
Mar 23, 2026 at 11:32pm UTC

ManagementDB Europe recovered.

Updated
Mar 23, 2026 at 11:30pm UTC

ManagementDB Canada recovered.

Updated
Mar 23, 2026 at 11:27pm UTC

ManagementDB Australia is degraded.

Updated
Mar 23, 2026 at 11:24pm UTC

ManagementDB Canada is degraded.

Updated
Mar 23, 2026 at 11:18pm UTC

ManagementDB Europe is degraded.

Updated
Mar 23, 2026 at 7:00pm UTC

ManagementDB Australia and ManagementDB Europe recovered.

Updated
Mar 23, 2026 at 6:51pm UTC

ManagementDB Australia is degraded.

Updated
Mar 23, 2026 at 6:35pm UTC

ManagementDB Europe is degraded.

Updated
Mar 23, 2026 at 4:45pm UTC

AnalyticsDB WestEurope recovered.

Updated
Mar 23, 2026 at 4:18pm UTC

AnalyticsDB WestEurope is degraded.

Updated
Mar 23, 2026 at 4:01pm UTC

Global SaaS Status is degraded.

Updated
Mar 23, 2026 at 2:40pm UTC

Global SaaS Status recovered.

Updated
Mar 23, 2026 at 2:32pm UTC

Global SaaS Status is degraded.

Updated
Mar 23, 2026 at 2:31pm UTC

Global SaaS Status recovered.

Updated
Mar 23, 2026 at 2:14pm UTC

Global SaaS Status is degraded.

Updated
Mar 23, 2026 at 10:41am UTC

Global SaaS Status recovered.

Updated
Mar 23, 2026 at 10:21am UTC

Global SaaS Status is degraded.

Updated
Mar 23, 2026 at 10:18am UTC

Global SaaS Status recovered.

Updated
Mar 23, 2026 at 10:02am UTC

Global SaaS Status is degraded.

Updated
Mar 23, 2026 at 10:00am UTC

Global SaaS Status recovered.

Updated
Mar 23, 2026 at 6:09am UTC

ManagementDB APAC recovered.

Updated
Mar 23, 2026 at 6:03am UTC

ManagementDB APAC is degraded.

Updated
Mar 21, 2026 at 11:16pm UTC

AnalyticsDB USA recovered.

Updated
Mar 21, 2026 at 11:04pm UTC

AnalyticsDB USA is degraded.

Updated
Mar 21, 2026 at 6:08am UTC

ManagementDB Europe recovered.

Updated
Mar 21, 2026 at 6:03am UTC

ManagementDB Europe is degraded.

Updated
Mar 20, 2026 at 12:16pm UTC

AnalyticsDB USA recovered.

Updated
Mar 20, 2026 at 12:10pm UTC

AnalyticsDB USA is degraded.

Updated
Mar 18, 2026 at 11:04am UTC

Global SaaS Status is degraded.

Updated
Mar 18, 2026 at 11:02am UTC

Global SaaS Status recovered.

Created
Mar 18, 2026 at 10:09am UTC

Global SaaS Status is degraded.