Global SaaS Status and AnalyticsDB WestEurope are down
Resolved
Mar 30, 2026 at 11:18am UTC
AnalyticsDB WestEurope recovered.
Affected services
Updated
Mar 30, 2026 at 3:50am UTC
Global SaaS Status recovered.
Affected services
Updated
Mar 30, 2026 at 3:40am UTC
Global SaaS Status is degraded.
Affected services
Updated
Mar 30, 2026 at 3:39am UTC
Global SaaS Status recovered.
Affected services
Updated
Mar 30, 2026 at 3:34am UTC
Global SaaS Status is degraded.
Affected services
Updated
Mar 30, 2026 at 3:26am UTC
Global SaaS Status recovered.
Affected services
Updated
Mar 30, 2026 at 3:21am UTC
Global SaaS Status is degraded.
Affected services
Updated
Mar 30, 2026 at 3:20am UTC
Global SaaS Status recovered.
Affected services
Updated
Mar 30, 2026 at 3:15am UTC
Global SaaS Status is degraded.
Affected services
Updated
Mar 30, 2026 at 3:12am UTC
Global SaaS Status recovered.
Affected services
Updated
Mar 30, 2026 at 3:05am UTC
Global SaaS Status is degraded.
Affected services
Updated
Mar 30, 2026 at 12:26am UTC
Global SaaS Status recovered.
Affected services
Updated
Mar 30, 2026 at 12:20am UTC
Global SaaS Status is degraded.
Affected services
Updated
Mar 30, 2026 at 12:11am UTC
Global SaaS Status recovered.
Affected services
Updated
Mar 30, 2026 at 12:02am UTC
Global SaaS Status is degraded.
Affected services
Created
Mar 29, 2026 at 1:58pm UTC
AnalyticsDB WestEurope is degraded.
Affected services