Global SaaS Status is down
Resolved
Apr 13, 2026 at 9:18am UTC
Global SaaS Status recovered.
Affected services
Updated
Apr 13, 2026 at 9:05am UTC
Global SaaS Status is degraded.
Affected services
Updated
Apr 13, 2026 at 4:11am UTC
Global SaaS Status recovered.
Affected services
Updated
Apr 13, 2026 at 4:06am UTC
Global SaaS Status is degraded.
Affected services
Updated
Apr 13, 2026 at 4:05am UTC
Global SaaS Status recovered.
Affected services
Updated
Apr 13, 2026 at 4:00am UTC
Global SaaS Status is degraded.
Affected services
Updated
Apr 13, 2026 at 3:30am UTC
Global SaaS Status recovered.
Affected services
Updated
Apr 13, 2026 at 3:15am UTC
Global SaaS Status is degraded.
Affected services
Updated
Apr 13, 2026 at 2:20am UTC
Global SaaS Status recovered.
Affected services
Updated
Apr 13, 2026 at 2:08am UTC
Global SaaS Status is degraded.
Affected services
Updated
Apr 13, 2026 at 1:42am UTC
Global SaaS Status recovered.
Affected services
Created
Apr 13, 2026 at 1:25am UTC
Global SaaS Status is degraded.
Affected services