Global SaaS Status is down
Resolved
Apr 20, 2026 at 4:55am UTC
Global SaaS Status recovered.
Affected services
Updated
Apr 20, 2026 at 4:49am UTC
Global SaaS Status is degraded.
Affected services
Updated
Apr 20, 2026 at 4:15am UTC
Global SaaS Status recovered.
Affected services
Updated
Apr 20, 2026 at 4:08am UTC
Global SaaS Status is degraded.
Affected services
Updated
Apr 20, 2026 at 4:03am UTC
Global SaaS Status recovered.
Affected services
Updated
Apr 20, 2026 at 3:54am UTC
Global SaaS Status is degraded.
Affected services
Updated
Apr 20, 2026 at 3:48am UTC
Global SaaS Status recovered.
Affected services
Updated
Apr 20, 2026 at 3:39am UTC
Global SaaS Status is degraded.
Affected services
Updated
Apr 20, 2026 at 3:32am UTC
Global SaaS Status recovered.
Affected services
Updated
Apr 20, 2026 at 3:20am UTC
Global SaaS Status is degraded.
Affected services
Updated
Apr 20, 2026 at 3:12am UTC
Global SaaS Status recovered.
Affected services
Created
Apr 20, 2026 at 3:05am UTC
Global SaaS Status is degraded.
Affected services